Category Archives: Sieci komputerowe

Sieci komputerowe

Konfiguracja modemu routera DGT VDSL2 FG4 w tryb bridge PPPoE na usłudze Orange VDSL2

Aby skonfigurować modem / router DGT VDSL2 FG4 w tryb bridge PPPoE na usłudze Orange VDSL2 należy wejść w tryb zaawansowane -> Interfejsy -> WAN, usunąć interfejs ppp1.1 a następnie dodać interfejs ptm0.1 o parametrach:
type: Bridge;
Vlan802.1p: 0;
VlanMuxId: 35

Po modyfikacji można podłączyć do modemu DGT do portu ETH 1 lub 2 lub 3 inny router i skonfigurować na jego porcie WAN (podłączonym do DGT) połączenie PPPoE.
Do portu ETH4 (port żółty) modemu DGT nadal można podłączyć dekoder TV UHD88.

W powyższej konfiguracji, gdzie DGT pracuje tylko w trybie Bridge należy również:
– wyłączyć interfejs WLAN;
– zmienić hasło dostępu do urządzenia;
– wyłączyć serwer DHCP;
– ustawić jego adres IP na inny niż router w sieci LAN, nawiązujący połączenie PPPoE (lub nawet z innej podsieci). Wówczas można podpiąć któryś z wolnych portów ETH 1/2/3 DGT do switcha routera, aby można było się zalogować do DGT i podglądać np. parametry łącza.

źródło:
https://www.elektroda.pl/rtvforum/topic2242445.html
https://eko.one.pl/forum/viewtopic.php?id=8860
https://nasz.orange.pl/t5/Modemy-i-routery/DGT-VDSL2-FG4-JAKO-BRIDGE-PPPoE/td-p/51159

MikroTik – blokowanie stron WWW

Do tej pory aby zablokować stronę WWW należało posługiwać się regułami L7 (wyrażeniami regularnymi Regexp), lub Web Proxy. Niestety, używając tych funkcji RouterOS, blokowanie wielu stron WWW mogło spowodować nadmierne obciążenie CPU.
Poczynając od wersji RouterOS 6.36,  istnieje możliwość używania nazw DNS w address-list. Daje to ogromne możliwości firewalla – budowanie dynamicznych list IP. Blokowanie stron używając Dynamic Lists nie powoduje już dużego obciążenia CPU.

Poniżej przedstawiony jest przykład blokowania strony chomikuj.pl wszystkim komputerom w sieci oprócz komputera o adresie IP: 192.168.5.107:

miktorik - blokowanie stron, ustawienia firewalla

Na powyższym zrzucie ekranu widać, że MikroTik rozwiązał nazwę DNS chomikuj.pl i umieścił dynamiczne wpisy IP w Address Lists.  W tym przypadku strona chomikuj.pl dostępna jest pod dwoma adresami IP.

MikroTik – logowanie ruchu w sieci, monitorowanie łącza i samego urządzenia

Aby logować nawiązywane połączenia w sieci należy logować wszystkie połączenia TCP z flagą SYN oraz FIN.

W tym celu w terminalu należy wpisać poniższe komendy:

ip firewall filter add chain=forward action=log tcp-flags=syn protocol=tcp log=yes log-prefix="all-connections"
ip firewall filter add chain=forward action=log tcp-flags=fin protocol=tcp log=yes log-prefix="all-connections"
system logging add action=remote prefix=all-connections topics=firewall

Bardzo dobrym programem dla systemu Windows zapisującym logi z MT jest Kiwi Syslog Server ( https://www.kiwisyslog.com/downloads ). Dla większości użytkowników wersja darmowa – ograniczona jest wystarczająca.

Innym b. dobrym i całkowicie darmowym syslogiem jest Visual Syslog Server for Windows (https://sourceforge.net/projects/syslogserverwindows/)

Kolejnym świetnym programem służącym do zliczania ruchu w sieci jest Attix Traffic Monitor 1.0.3 do ściągnięcia ze strony: https://forum.mikrotik.com/viewtopic.php?t=77193 lub http://www.mikrotik.com/download/TrafficCounter.zip .

Na stronie: https://lifeisrouting.blogspot.com/2016/06/mikrotik-kiwi-syslog-configuration.html

przedstawiona jest konfiguracja logowania ruchu przez WebProxy.

 

Poniżej wymienione są inne programy do monitorowania łącza oraz samego urządzenia (obciążenie CPU, RAM itp…)
https://www.youtube.com/watch?v=84keY6KOw2I – Mikrotik WebProxy logs
http://www.itlearnweb.com/2016/01/how-to-save-mikrotik-logs-to-remote_56.html – log connections
https://www.youtube.com/results?search_query=mikrotik+kiwi+syslog+server
https://lifeisrouting.blogspot.com/2016/06/mikrotik-kiwi-syslog-configuration.html
https://trzepak.pl/viewtopic.php?f=26&t=49897&start=25
https://kazuko.pl/
https://www.paessler.com/
https://www.librenms.org
https://www.icinga.com/

 

 

 

 

MikroTik – dhcp server problem

Od wersji RouterOS 6.38 występuje problem z serwerem DHCP. Mianowicie, serwer przestaje odpowiadać na zapytania i nie przydziela adresów:

20:19:22 dhcp,warning DHCP offering lease 192.168.5.60 for 08:00:0F:8F:C0:0E without success

W przypadku RB951Ui-2HnD serwer DHCP przydzielał adresy IP tylko komputerom połączonym drogą radiową (na interfejsie wlan1). Komputery podpięte do routera przez Ethernet nie otrzymywały adresów IP, mimo że interfejs wlan1 oraz Ethernet były skonfigurowane w trybie bridge.

Doraźnym rozwiązaniem jest restart serwera DHCP. Jednak problem powraca po długiej nieaktywności serwera DHCP (np po weekendzie).

Rozwiązaniem problemu jest wyłączenie protokołu RTSP na interfejsie bridge oraz włączenie go ponownie.

Problem opisany jest na oficjalnym forum MikroTika: https://forum.mikrotik.com/viewtopic.php?t=116963

Gdzie Winbox przechowuje hasła

Winbox w systemach: Windows 7, Windows 8, Windows 8.1, Windows 10 przechowuje hasła w lokalizacji: C:\Users\%USERNAME%\AppData\Roaming\Mikrotik\Winbox\Addresses.cdb
Warto od czasu do czasu edytować plik i podejrzeć czy nie ma w nim zapisanych haseł (np. omyłkowo wpisanych w polu Connected To) , gdyż będą one widoczne.

Aktualizacja oprogramowania Tomato na routerze ASUS RT-N10U

Najprostszym sposobem aktualizacji oprogramowania na routerze ASUS RT-N10U jest użycie oficjalnego narzędzia ASUS Firmware Restoration version 2.0.0.0, które można pobrać ze strony: http://dlcdnet.asus.com/pub/ASUS/wireless/RT-N10U_B1/Rescue_RT_N10U_B1_2000.zip . Następnie należy:

  1. Ze strony http://tomato.groov.pl/download/K26RT-N/ ściągnąć najnowszy obraz oprogramowania Tomato o wielkości nie przekraczającej 8MB, np najnowszy obraz na dzień 17.08.2015: http://tomato.groov.pl/download/K26RT-N/build5x-131-EN/Asus%20RT-Nxx/tomato-K26USB-1.28.RT-N5x-MIPSR2-131-VPN.zip, rozpakować plik *.trx
  2. Na komputerze połączonym z routerem ustawić adres IP: 192.168.1.10
  3. W programie wybrać Firmware Restoration wybrać obraz *.trx i nacisnąć klawisz „Prześlij”,
  4. Przytrzymując przycisk reset, włączyć urządzenie.
  5. Rozpocznie się proces kopiowania obrazu. Po przekopiowaniu program wyświetli komunikat o pomyślnie przeprowadzonej operacji.

Mikrotik – automatyczne odnawianie publicznego adresu IP

W przypadku dynamicznego adresu IP (np. Neostrada) bardzo przydatna jest funkcja automatycznego odnawiania adresu IP o określonej porze (np. o 5.00 rano), gdy użytkownicy jeszcze nie korzystają z sieci. Bardzo niemiła jest bowiem sytuacja jeśli zmienia się adres IP w ciągu dnia pracy, np. podczas sesji bankowej itp.

/interface pppoe-client set [find name="pppoe-out1"] disabled=yes
/interface pppoe-client set [find name="pppoe-out1"] disabled=no
/log info message="PPPoE reconnect"

Ustawienie Schedulera:

/system scheduler add name=”WANdisconnect” on-event=nazwaPowyzszegoSkryptu start-date=jan/01/1970 start-time=00:05:00 interval=1d comment=”” disabled=no