Windows – jak wyłączyć skype

Aby całkowicie wyłączyć Skype w systemie Windows (zamknąć wszystkie jego procesy) należy utworzyć plik .bat z następującymi wpisami:

taskkill /f /im skypeapp.exe
taskkill /f /im skypehost.exe
taskkill /f /im SkypeBridge.exe
taskkill /f /im SkypeBackgroundHost.exe
taskkill /f /im RuntimeBroker.exe
pause

Aby odinstalować Skype należy uruchomić PowerShell z podniesionymi uprawnieniami i wydać polecenie:


get-appxpackage *skype* | remove-appxpackage

CentOS 7 – automatic login, disable automatic logout

W celu konfiguracji automatycznego logowania do sytemu należy edytować plik: /etc/gdm/custom.conf i w sekcji [daemon] wpisać dwie instrukcje:

 AutomaticLogin=nazwa_uzytkownika
AutomaticLoginEnable=True

Aby wyłączyć automatyczne wylogowywanie po np. 5 minutach należy wejść w Ustawienia -> Zasilanie i w sekcji Oszczędzanie energii -> Wygaszanie ekranu ustawić czas na „nigdy”.

CentOS 7 – instalacja i konfiguracja serwera RDP

Należy ściągnąć repozytorium EPEL (Extra Packages for Enterprise Linux) ze strony li.nux.ro/repos.html lub wydając komendę:

 wget http://li.nux.ro/download/nux/dextop/el7/x86_64/nux-dextop-release-0-5.el7.nux.noarch.rpm
yum localinstall nux-desktop-release-0-5.el.nux.noarch.rpm
yum install xrdp tigervnc-server
systemctl start firewalld
firewall-cmd --permanent --zone=public --add-port=3389/tcp
firewall-cmd --reload
chcon --type=bin_t /usr/sbin/xrdp
chcon --type=bin_t /usr/sbin/xrdp-sesman
systemctl start xrdp.service

W kliencie RDP należy zaznaczyć True Color (24 bit) – nie Highest Quality32

Na koniec należy dodać serwis xrdp do autostartu:

systemctl enable xrdp.service

CentOS 7 – instalacja i konfiguracja serwera VNC

yum install tigervnc-server
cp /usr/lib/systemd/system/vncserver@.service /etc/systemd/system/vncserver-root@.service
gedit /etc/systemd/system/vncserver-root@.service

na końcu pliku należy zastąpić 2 wpisy nazwą użytkownika, dla którego chcemy uruchomić serwer, np. root. Drugi wpis odpowiada za automatyczny start podczas logowania na danym koncie użytkownika.
Założenie użytkownikowi hasła VNC:

vncpasswd 
systemctl daemon-reload
systemctl start vncserver-root@:1.service
systemctl start firewalld
firewall-cmd --permanent --zone=public --add-port=5901/tcp
firewall-cmd --reload

Jeżeli występuje problem z uruchomieniem serwera VNC, wyświetla się komunikat:

Job for vncserver-root@1.service failed because a configured resource limit was exceeded. See „systemctl status vncserver-root@:1.service” and „journalctl -xe” for details

należy zrestartować usługę:

 systemctl stop vncserver-root@:1.service
systemctl start vncserver-root@:1.service

oraz usunąć plik .X0-lack w /tmp
oraz plik X1 z katalogu /tmp/.X11-unix

komenda do listowania plików: ls -la

MikroTik – discover fake DHCP server

Aby wykryć inny serwer DHCP w sieci należy skonfigurować Alert w serwerze DHCP routera MirkoTik:

/ip dhcp-server alert
add interface=bridge1 valid-server=xx:xx:xx:xx:xx:xx
add disabled=no interface=bridge1 on-alert="/tool e-mail send to=\"E-MAIL_ADDRESS@gmail.com\" subject=\"\$[/system identity get name] - Fake DHCP Server discovered \$[/system clock get time]\"" \
valid-server=xx:xx:xx:xx:xx:xx

gdzie:
valid-server=xx:xx:xx:xx:xx:xx – adres MAC serwera DHCP,
interface=bridge1 – bridge/interfejs na którym działa serwer DHCP

W artykule http://obsluga-it.pl/mikrotik-backup-to-e-mail/ została opisana konfiguracja serwera e-mail w routerze MikroTik.

MikroTik – backup to e-mail

W celu konfiguracji automatycznej kopii ustawień
routera MikroTik na e-mail należy najpierw skonfigurować konto pocztowe. Poniżej przedstawiona jest konfiguracja dla konta Gmail. Zamiast „USER_NAME_TYPE_HERE ” należy wpisać swoją nazwę (login) użytkownika Gmail a w polu ” PASSWORD_TYPE_HERE ” swoje hasło.
Należy również pamiętać, aby w konfiguracji powyższego konta zezwolić na korzystanie z niego na mniej bezpiecznych aplikacjach poprzez zaznaczenie opcji ON na stronie: https://myaccount.google.com/lesssecureapps .

/tool e-mail
set address=74.125.141.108 from=USER_NAME_TYPE_HERE@gmail.com password=PASSWORD_TYPE_HERE port=587 start-tls=yes user=USER_NAME_TYPE_HERE@gmail.com

Następnie należy stworzyć skrypt odpowiedzialny za utworzenie pliku z wszystkimi ustawieniami routera i wysłanie go na adres e-mail.

/system script
add dont-require-permissions=no name=backup2email owner=admin policy=ftp,reboot,read,write,policy,test,password,sniff,sensitive,romon source=\
"/export file=export\r\
\n/tool e-mail send to=\"WHERE_TO_SEND@gmail.com\" subject=\"\$[/system identity get name] export\" \\r\
\nbody=\" configuration file \$[/system clock get date]\" file=export.rsc"

Ostatnią czynnością jest dodanie wpisu w scheduler, aby kopia wykonywała się systematycznie (w tym przypadku co tydzień).

/system scheduler
add interval=1w name=Backup2email on-event="backup2email\r\
\n" policy=ftp,reboot,read,write,policy,test,password,sniff,sensitive,romon start-date=mar/13/2019 start-time=13:59:26