Category Archives: CISCO

Zabezpieczenie portów przełącznika CISCO

Konfiguracja portu przełącznika CISCO tak, aby do danego portu mogło być podłączone tylko jedno lub wiele urządzeń o podanych adresach MAC.

configure t
int range f0/1-15

Porty przełącznika domyślnie są ustawione jako Dynamic Auto. Należy je przestawić na Access Port.

switchport mode access

Przypisanie portom aktualnie podłączonych adresów MAC

switchport port-security mac-address sticky

Przypisanie portom przełącznika tylko jednego adresu MAC. Więcej adresów jest niedozwolonych.

switchport port-security max 1

Jeśli naruszy ktoś zasadę i podepnie do portu następny przełącznik i więcej urządzeń lub o innym adresie MAC, wtedy port się wyłączy.

switchport port-security violation shut

Zakończenie konfiguracji oraz jej zapamiętanie.

exit
exit
copy run start

Sprawdzenie zabezpieczenia portów, ich stanów (czyli informacji o ewentualnych naruszeniach polityki – kolumna SecurityViolation (Count)) oraz tablicy MAC:

sh port-security
sh mac-address-tabl

 

Wstępna konfiguracja przełącznika CISCO

//Introducing to Networking for CCNA
//Network Layer Addressing and Subnetting
//Configuring a CISCO Router
//Ethernet Operation and Switch Configuration
//VLAN Operation and Configuration

config
hostname Switch1
ip domain-name firma.pl
banner motd #to jest switch testowy#

//stworzenie hasła
enable secret cisco

//stworzenie użytkownika admin z hasłem cisco w celu połączenia przez SSH
username admin secret cisco

//wygenerowanie klucza i włączenia SSH
crypto key generate rsa

How meny bits on the modulus [512]: 2048

//włączenie SSH ver 2
ip ssh ver 2

//zaszyfrowanie wszystkich haseł w systemie
service password-encryption

//zabezpieczenie hasłem dostępu przez konsolę
line con 0
password cisco

//wymuszenie podania loginu przy dostępie przez konsolę
login

//konfiguracja połączenia ssh, vtv 0 4 znaczy że urządzenie pozwala na 5 jednoczesnych połączeń przez Telnet lub SSH
line vty 0 4
login local
transport input ssh
exit

//stworzenie wirtualnego interfejsu SVI (switch virtual interface) w celu połączenia SSH
interface vlan1
ip address 10.0.0.5 255.255.255.0
no shutdown
exit

show running

copy running-config startup-config